Atom编辑器代理设置

Atom编辑器作为GitHub研发的一款针对开发者的编辑器,以其轻量性一下子就吸引了很多的受众.虽然问题一直存在,但我们期待着它不断的更新和进步.但最近更新的版本之后,打开编辑器之后就马上闪退.后来发现原来是代理的问题,作为习惯使用谷歌搜索的忠实用户,面对鱼和熊掌不可得兼的尴尬确实很头疼.

代理冲突

shadowsock 代理

shadowsocks代理与Atom编辑器冲突导致编辑器闪退,所以需要分别在shadowsocks的代理配置文件和Atom配置文件配置好代理即可;

代理配置文件

在电脑右下角小飞机图标中找到代理配置文进PAC,选择编辑本地PAC文件.针对Atom新增记录值 proxy:8080;
为防止代理配置文件在同步更新线上文件的时候被覆盖,最好设置保护本地文件选项;

编辑器配置文件

1
2
3
apm config set registry https://registry.npm.taobao.org
apm config set strict-ssl false
apm config set https-proxy https://proxy:8080

如上第三步骤,解决代理的问题关键在于设置本地代理.

检查测试

查看代理设置是否成功,除了开启代理和编辑器查看是否冲突闪退之外,还是测试下代理配饰是否可用.

1
2
apm config get https-proxy
apm install --check

可以通过以下命令查看代理是否可用.

参考资料

Atom代理设置

文章目录
  1. 1. 代理冲突
    1. 1.1. shadowsock 代理
      1. 1.1.1. 代理配置文件
      2. 1.1.2. 编辑器配置文件
      3. 1.1.3. 检查测试
  2. 2. 参考资料